Linux:Won't Run OOTB

History: I have faced this same issue with Standard Notes (Trying to Install on MX Linux · Issue #1120 · standardnotes/forum · GitHub) and Joplin (Can't open on MX Linux - #8 by yogaturtle - Support - Joplin Forum) and now I am having the same issue with CrossClave In MX Linux the ‘–no-sandbox’ startup parameter does get the application running but security-wise it is not ideal.

I am also trying to get the Linux version running under Qubes OS using the Debian-10 Qube. The application does start briefly but is followed by a dialog that says ‘Account loading problem. There was a problem loading your account’ with a single ‘ok’ button. When I press this, on the main screen, it says ‘Something Didn’t Work!’ and then ‘Do us a favor, please close and reopen CrossClave to try again.’

Restarting the application does not work. This exact error is also present when I add the ‘–no-sandbox’ switch to the command line.

1 Like

I have the same issue. Installed CrossClave on Debian, no errors reported, and when I try to run it I get the same error message. I’ve tried closing and reopening multiple times, always the same error. CrossClave just won’t run on my Debian desktop.

@sgosnell ,

What I found works with Debian is to start a terminal and then type:

crossclave --no-sandbox

Install packages from outside the repos, then use --no-sandbox? Seriously? For something that purports to be all about security? No thanks, I’ll just forget about CrossClave for now, until they get their stuff together. FWIW, I did try that one time, just to see, and it still won’t run, same error. It’s not even close to being ready for prime time. Amateurs.

1 Like


Lots of apps are affected by this design flaw. They have in common:

  1. packged Electron app as an appImage
  2. oldish Debian kernel (and siblings)
  3. Electron imposed sandbox

I have encountered this personally with Joplin, Standard Notes and now Crossclave. This bug is years old. No one wants to fix it and most don’t want to talk about it. See my investigation at Standard Notes on Github

1 Like

My biggest complaint is that the company complains about the lack of security online, then expects users to install software from unsecure sources, plus run that software unsandboxed. That is unacceptable. Appimages, snap packages, etc are also unacceptable. I know that Ubuntu thinks they’re wonderful, but I won’t run Ubuntu.

Just updated my MX Linux PC (Debian 10) to Crossclave 13 and the Electron sandbox bug is still present.

Nor will anyone else concerned with security and privacy.

This is old… very old we hope that it’s something that we can change in the future … and still hasn’t been fixed (a year later). But there’s certainly a lot of finger pointing going on, enough to dissuade me from bothering to continue, or considering deploying insecure software, especially when those are the official recommendations by the vendor - Finger pointing doesn’t make your software production ready.

This platform is beta software, certainly not ready for production deployment, and as such, it is irresponsible to advertise it as so.